Registrarse Gratis

¡Únase para Aprender y Compartir!

Factura Electrónica en Tango - Conexión Fallida

21/2/2017 11:43AM
Buenos días! Hace varios días que estoy intentando hacer funcionar el último certificado emitido por la AFIP para la emisión de facturas electrónicas. Hoy vence el viejo certificado y no logro hacer funcionar el nuevo. Trabajo en la administración de una PYME y usamos el Tango. He leído detenidamente el problema que tuvo otro de los usuarios en esta página (http://software.yoreparo.com/software_de_gestion/afip-me-rechaza-las-facturas-electronicas-t1487406.html), pero mi problema croe que es otro. Ya intentó ver el inconveniente varias veces la empresa que nos hace el service del Tango, así como el técnico de la organización, sin obtener una respuesta favorable. El cartel que figura al tratar de instalar el nuevo certificado es siempre el mismo: "Conexión fallida. No se pudo generar la autenticación para enviar a la A.F.I.P. Verifique que se encuentren bien configurados los parámetros de conexión o que el certificado no coincida con la clave privada generada (KL001)". El inconveniente es que hemos bajado en reiteradas oportunidades el certificado y emitido la clave también. Intento de distintas formas agregar estos datos en los Parámetros en la Administración de Comprobantes Electrónicos, pero el resultado es extraño: muy pocas veces me dice Conexión Exitosa, pero por sólo unos minutos, porque al volver a intentar probarlo, me salta el cartel que detallé. Eso no sucede cuando cargo el viejo certificado, que lo toma sin problema alguno. Los dos certificados están guardados en una carpeta de acceso rápido: C:UsersKay08DocumentsMis certificados (dentro de éste, una carpeta con el certificado viejo y otra con el certificado nuevo). Mi computadora, al igual que el resto, está en red. El sistema Tango está guardado en un servidor general. Alguien podría ayudarme? La gente de Tango no me ha sabido dar una respuesta, y prácticamente me soltó la mano. Hice una consulta web a la AFIP pero aún no recibo respuesta (y mañana ya no podré emitir más facturas electrónicas). Tampoco logro comunicarme por teléfono a la agencia de la AFIP más cercana. Desconozco si el problema es de mi computadora, de AFIP o del Tango, pero necesito una solución. Dónde podría estar el problema? Muchas gracias al que me responda!
Esta pregunta está cerrada. Si quieres puedes: Abrir otra Pregunta
21/2/2017 04:05PM
Procedimiento:
1. Reemplazá el ejecutable Cliente\Aplicaciones\AxCertSetup.exe por el siguiente:
https://1drv.ms/u/s!AvopgFWbvDXfgQWnIOSvW3xkwxnn
2. Generar el REQ mediante el Asistente, el mismo estará encriptado en 4096 bits (compatible con AFIP) en lugar de en 1024 bits (tu problema actual).
3. En clave Fiscal, dentro del mismo Alias, levantá el REQ.
4. Bajá el Certificado generado.
5. Recordá que el conjunto Certificado+Privada+Source+Requerimiento es UNICO...! No se pueden mezclar entre ellos...! Identificalos por la fecha de HOY.
6. Apuntá en Parámetros: el Certificado en el primer cuadro, la Privada en el segundo, y copiá el contenido de Source en "Identificación de origen". Colocá 60 segundos de espera.

NOTA: el email del operador no tiene que ser real, como tampoco la contraseña. No se usan Wink

Cualquier duda consultás. Saludos!
Tangos Site Admin Colaborador: En un momento que YoReparo lo necesitó este usuario hizo su colaboración para para el bien de todos 10.598K
ASISTIÓ A LA SOLUCIÓN
21/2/2017 04:08PM
Algo adicional:
La red en general y tu equipo en particular deben estar sincronizados con la red de AFIP.
Para eso, tu técnico debe configurar el SNTP contra el de AFIP.
Si no lo sabe, que te lo diga y te explico, es función del Sistema Operativo.
Esto debe hacerse SI o SI, sin vueltas.
Saludos!
Tangos Site Admin Colaborador: En un momento que YoReparo lo necesitó este usuario hizo su colaboración para para el bien de todos 10.598K
21/2/2017 04:26PM
Gracias! Mañana voy a intentar. Pero tengo el maldito inconveniente (como extra a mi problema) que no puedo hacer ninguna modificación del sistema ni ejecutar ningún archivo si no ingreso una clave del sistema, que el mismo personal del sector se niega a dármelo por una cuestión de seguridad. Conclusión: por cada intento, tengo que llamar al técnico a que se siente al lado para cargar el usuario y la clave. Lo curioso de esto es que eventualmente parecería que lo toma al nuevo certificado, pero solo por unos minutos, y luego vuelve a fallar. Hoy llegué a emitir una factura y una nota de crédito con el nuevo certificado. Si bien me tiraba error al tratar de aprobarlo, cuando volvía a pedir el CAE, me lo aprobaba. Pero esto duró unos minutos, hasta que definitivamente volvió a saltar el error (sin posibilidad de darlo vuelta).
Mañana vuelvo a intentar y me comunico. Gracias por darme una alternativa para probar (ya se me quemaron los libros! estoy así hace más de dos semanas!).
Saludos!
21/2/2017 07:57PM
En vista del último comentario, el problema no es con el nuevo Certificado.
No es necesario obtener uno nuevo.

Si a veces se obtiene CAE y a veces no, puede ocurrir que los servidores de AFIP estén ocupados.
Por ello es recomendable colocar el tiempo de espera en 60 segundos en lugar de 30 (en Parámetros, en Administración de Comprobantes Electrónicos).
Si cambiando el tiempo de espera se soluciona, listo.

Otra opción es que haya un defasaje de tiempos entre tu equipo y el servidor de AFIP. Es un tema técnico, de acuerdo a lo que comentás es un cambio que debe realizar alguien con permisos administrativos sobre el equipo. Lamentablemente, se requiere de altos conocimientos técnicos, no para realizar el cambio, ya que es sólo una línea de texto, sino para comprender dicho cambio y como afecta al rendimiento de la red y las comunicaciones.

Si pudieras ZIPear el archivo:
C:\ProgramData\Axoft\Logs\prFacturaElectronicaAR.log
y subirlo a algún gestor de archivos online, y colocar el enlace hacia él, puedo analizarlo ya que allí figura la razón del problema.

Saludos!
Tangos Site Admin Colaborador: En un momento que YoReparo lo necesitó este usuario hizo su colaboración para para el bien de todos 10.598K
22/2/2017 10:18AM
Hola! No creo que sea problema del servidor de la AFIP, porque eso lo fui controlando cada vez que probaba el certificado y siempre me dio respuesta OK. Hoy el viejo certificado ya caducó y estoy sin poder emitir facturas electrónicas. El nuevo certificado me da "Conexión Fallida" como error y no puedo ni remotamente hacerlo funcionar (ayer, si se alineaban los planetas, lograba que ande un rato; hoy ya no). El técnico ayer estuvo viendo lo de la fecha y hora, pero lo dejé trabajando y me fui, no sé si pudo hacer algún cambio porque aún no lo volví a ver. Dónde debería pegar el enlace que me enviaste? A ver si logro adelantar algo...
Lo del CAE de ayer fue por la emisión de la factura cuando el nuevo certificado quedaba andando, pero me costaba aprobar la factura. Hoy ya directamente no anda. Igual probé lo del tiempo de espera, pero no dio resultado.
Volviendo al posible inconveniente de la fecha y la hora, no debería haber sido un problema de entrada? Me refiero a que si estuvieran desfasadas con el servidor de la AFIP, nunca tendría que haber funcionado ningún certificado, pero en mi caso, el viejo certificado andaba bien, y el nuevo muy esporádicamente también (hasta ayer)...
22/2/2017 01:49PM
No es un enlace, es un archivo presente en tu equipo.
Lo tenés que zipear y subir a algún gestor de archivos online (OneDrive, Google Drive, etc.) y postear el enlace al mismo, para que yo lo pueda bajar y analizar.
Saludos!
Tangos Site Admin Colaborador: En un momento que YoReparo lo necesitó este usuario hizo su colaboración para para el bien de todos 10.598K
23/2/2017 01:53PM
Buenos días, Tangos! Tengo la excelente noticia de que pudimos hacer andar la facturación electrónica. Desconozco cuál habrá sido el error de base, tampoco logro entender cómo es que pudieron funcionar los archivos tal como los pusimos, pero anduvo y anda sin problemas! Tuve que generar un nuevo alias, crear un nuevo certificado en la AFIP y cargar éste con la clave y el txt viejo. No entiendo cómo la clave y txt de un alias, puede funcionar con un certificado de otro alias. Me puso muy nerviosa que no tuviera una ayuda constante para el proceso: la gente de Tango andaba ocupada y pocas veces me ayudó ante el primer tropiezo, el chico de sistemas no era muy hábil en aplicar soluciones alternativas al inconveniente, tampoco disponían del tiempo...
Más allá de todo, lo importante es que hoy solucionamos el problema (con otro técnico). Te agradezco muchísimo la ayuda que me diste, pese a que pocas veces pude ejecutar tus alternativas (porque se escapa muchas veces de mis conocimientos informáticos). Rescato la buena predisposición y desinterés de la gente para un desconocido como yo. Muchísimas gracias por las respuestas! Saludos más que cordiales!!!!
23/2/2017 02:11PM
Me alegro mucho...!
El "alias" es un invento de Afip, en realidad no participa del proceso de certificación de la información.
Podés reusarlo teniendo en cuenta que los datos que figuran como "DN" sólo se corresponden al primer REQ subido, no al último (o sea, pueden variar).
Todo es muy técnico, lo importante es que ya está funcionando.

Cierro el tema. Saludos!
Tangos Site Admin Colaborador: En un momento que YoReparo lo necesitó este usuario hizo su colaboración para para el bien de todos 10.598K
comentario
Esta pregunta está cerrada. Si quieres puedes: Abrir otra Pregunta

Bienvenido/a!

YoReparo es la mayor comunidad sobre tecnología. Colaboramos y compartimos información para solucionar todo tipo de problemas técnicos.

Para participar solo hace falta que te registres gratis aquí

Todos los Foros